Reef Central Online Community
Aquarium

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Royal Exclusiv / Bubble King
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 12/13/2017, 01:43 PM   #1
MrsBugmaster
Registered Member
 
Join Date: Nov 2008
Location: Indiana
Posts: 171
Rust in pump

I have a RD 3 Speedy 80 Watt dc pump and when dong my maintains this week I discovered rust on the inside of the pump and one the rotor. What is the warranty on this pump? I think the pump is just 3 year old.






__________________
Mom of Army Hero 06 20 2011 Never Forgotten / Always Remembered

Current Tank Info: Red Sea Reefer 170, my reef tank. 180 gal FOWLR tank
MrsBugmaster is offline   Reply With Quote
Old 12/13/2017, 01:47 PM   #2
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 12,756
Warranty is 2 years. That cover over the magnet is titanium. My guess is that the rust is from GFO or something else. Use some steel wool to clean the magnet and the magnet cavity. You should be just fine. That said, not sure if it's just the reflection but it looks like something was rubbing inside the magnet cavity.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Old 12/13/2017, 01:49 PM   #3
MrsBugmaster
Registered Member
 
Join Date: Nov 2008
Location: Indiana
Posts: 171
No GFO used on this tank. There where some of those little snails that got in it. I guess they damaged it.


__________________
Mom of Army Hero 06 20 2011 Never Forgotten / Always Remembered

Current Tank Info: Red Sea Reefer 170, my reef tank. 180 gal FOWLR tank
MrsBugmaster is offline   Reply With Quote
Old 12/13/2017, 01:53 PM   #4
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 12,756
Quote:
Originally Posted by MrsBugmaster View Post
No GFO used on this tank. There where some of those little snails that got in it. I guess they damaged it.
I would scrub it off as mentioned above then inspect the magnet closely to make sure the titanium cover has not been compromised.It could be from something else that the pump sucked up and stuck to the magnet. If all looks well, then you should be just fine. Just check it again on your next maintenance or soon if you choose.

If you have a scotch brite pad, that might be better than steel wool since the steel wool will leave particles that will stick to the magnet and rust.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Old 12/13/2017, 01:56 PM   #5
MrsBugmaster
Registered Member
 
Join Date: Nov 2008
Location: Indiana
Posts: 171
Thanks for the help.


__________________
Mom of Army Hero 06 20 2011 Never Forgotten / Always Remembered

Current Tank Info: Red Sea Reefer 170, my reef tank. 180 gal FOWLR tank
MrsBugmaster is offline   Reply With Quote
Old 12/13/2017, 01:59 PM   #6
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 12,756
Quote:
Originally Posted by MrsBugmaster View Post
Thanks for the help.
You're very welcome. When you inspect, look closely where that rust on the magnet was and make sure the covering isn't compromised. Do the same in the motor block. If you have any further issues, feel free to PM me.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:45 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014